aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/python/usrp_mpm/simulator/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuel O'Brien <sam.obrien@ni.com>2020-07-21 12:43:55 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-10-28 15:25:48 -0500
commitbd278a4b936f3e30f51d7cb9ff489f3ff7215379 (patch)
tree0001f604bf57831c8b760f7c135f134d91e950c2 /mpm/python/usrp_mpm/simulator/CMakeLists.txt
parentd42ddc804118b2e9120c84efd477f9f4b3f8472e (diff)
downloaduhd-bd278a4b936f3e30f51d7cb9ff489f3ff7215379.tar.gz
uhd-bd278a4b936f3e30f51d7cb9ff489f3ff7215379.tar.bz2
uhd-bd278a4b936f3e30f51d7cb9ff489f3ff7215379.zip
sim: Support Configuration Files
This commit adds support for configuration files to the simulator. As of now, these files only change the source and sink of data samples, but they are easily extensible to add more configuration to the simulator. Signed-off-by: Samuel O'Brien <sam.obrien@ni.com>
Diffstat (limited to 'mpm/python/usrp_mpm/simulator/CMakeLists.txt')
-rw-r--r--mpm/python/usrp_mpm/simulator/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/mpm/python/usrp_mpm/simulator/CMakeLists.txt b/mpm/python/usrp_mpm/simulator/CMakeLists.txt
index e95709249..21f281e52 100644
--- a/mpm/python/usrp_mpm/simulator/CMakeLists.txt
+++ b/mpm/python/usrp_mpm/simulator/CMakeLists.txt
@@ -21,6 +21,7 @@ set(USRP_MPM_SIMULATOR_FILES
${CMAKE_CURRENT_SOURCE_DIR}/chdr_stream.py
${CMAKE_CURRENT_SOURCE_DIR}/rfnoc_common.py
${CMAKE_CURRENT_SOURCE_DIR}/stream_endpoint_node.py
+ ${CMAKE_CURRENT_SOURCE_DIR}/config.py
)
list(APPEND USRP_MPM_FILES ${USRP_MPM_SIMULATOR_FILES})
set(USRP_MPM_FILES ${USRP_MPM_FILES} PARENT_SCOPE)