aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/python/usrp_mpm/chips/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Jones <toni.jones@ni.com>2019-01-09 19:33:35 +0000
committerAaron Rossetto <aaron.rossetto@ni.com>2021-02-22 10:15:13 -0600
commit394530777b3ac656609cf98b3c9e35238e3fc296 (patch)
treea88bf88dc138dcfa3c0ea680f895890c90bc997f /mpm/python/usrp_mpm/chips/CMakeLists.txt
parent2e441d296b1f98fd4939d4008430e8814e777e0c (diff)
downloaduhd-394530777b3ac656609cf98b3c9e35238e3fc296.tar.gz
uhd-394530777b3ac656609cf98b3c9e35238e3fc296.tar.bz2
uhd-394530777b3ac656609cf98b3c9e35238e3fc296.zip
mpm: Add an LMK03328 base chip driver
Added an LMK03328 base chip driver which does basic register access, ID validation, and PLL lock validation. This will act as the base class for device specific drivers which control the chip. The code it similar to the LMK04828 and LMK04832 base driver classes but has a different register map structure. Register bitfield definitions were omitted and will be added on an as needed basis.
Diffstat (limited to 'mpm/python/usrp_mpm/chips/CMakeLists.txt')
-rw-r--r--mpm/python/usrp_mpm/chips/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/mpm/python/usrp_mpm/chips/CMakeLists.txt b/mpm/python/usrp_mpm/chips/CMakeLists.txt
index 9bd7b9372..1f64d8e2d 100644
--- a/mpm/python/usrp_mpm/chips/CMakeLists.txt
+++ b/mpm/python/usrp_mpm/chips/CMakeLists.txt
@@ -9,6 +9,7 @@ set(USRP_MPM_CHIP_FILES
${CMAKE_CURRENT_SOURCE_DIR}/__init__.py
${CMAKE_CURRENT_SOURCE_DIR}/lmk04828.py
${CMAKE_CURRENT_SOURCE_DIR}/lmk04832.py
+ ${CMAKE_CURRENT_SOURCE_DIR}/lmk03328.py
${CMAKE_CURRENT_SOURCE_DIR}/adf400x.py
${CMAKE_CURRENT_SOURCE_DIR}/ds125df410.py
)