aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/python/usrp_mpm/chips/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Jones <toni.jones@ni.com>2019-01-08 17:23:24 +0000
committerAaron Rossetto <aaron.rossetto@ni.com>2021-02-22 10:15:13 -0600
commit2e441d296b1f98fd4939d4008430e8814e777e0c (patch)
tree582c03600dd20a9443a90a9d9fbd9a3291526a0c /mpm/python/usrp_mpm/chips/CMakeLists.txt
parentecbb24505dc2662ecee9da1de95cf8f99dec0c9e (diff)
downloaduhd-2e441d296b1f98fd4939d4008430e8814e777e0c.tar.gz
uhd-2e441d296b1f98fd4939d4008430e8814e777e0c.tar.bz2
uhd-2e441d296b1f98fd4939d4008430e8814e777e0c.zip
mpm: Add an LMK04832 base chip driver
Added an LMK04832 base chip driver which does basic register access, ID validation, and PLL lock validation. This will act as the base class for device specific drivers which control the chip. The code is similar to the LMK04828 base driver class, but has a different register map structure.
Diffstat (limited to 'mpm/python/usrp_mpm/chips/CMakeLists.txt')
-rw-r--r--mpm/python/usrp_mpm/chips/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/mpm/python/usrp_mpm/chips/CMakeLists.txt b/mpm/python/usrp_mpm/chips/CMakeLists.txt
index 13704abf1..9bd7b9372 100644
--- a/mpm/python/usrp_mpm/chips/CMakeLists.txt
+++ b/mpm/python/usrp_mpm/chips/CMakeLists.txt
@@ -8,6 +8,7 @@ set(USRP_MPM_FILES ${USRP_MPM_FILES})
set(USRP_MPM_CHIP_FILES
${CMAKE_CURRENT_SOURCE_DIR}/__init__.py
${CMAKE_CURRENT_SOURCE_DIR}/lmk04828.py
+ ${CMAKE_CURRENT_SOURCE_DIR}/lmk04832.py
${CMAKE_CURRENT_SOURCE_DIR}/adf400x.py
${CMAKE_CURRENT_SOURCE_DIR}/ds125df410.py
)