aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorPhilip Balister <philip@opensdr.com>2010-09-09 10:02:10 -0400
committerPhilip Balister <philip@opensdr.com>2010-09-09 10:02:10 -0400
commitd2d5be27b09faee1481a763ce25e7b95460a46c9 (patch)
treef73e5c39fd7bc11e61e9327c07bc1ba8b5980de2 /host/utils/CMakeLists.txt
parentcd84e9dbfcc12584eba890a6618d38832e5d8dba (diff)
downloaduhd-d2d5be27b09faee1481a763ce25e7b95460a46c9.tar.gz
uhd-d2d5be27b09faee1481a763ce25e7b95460a46c9.tar.bz2
uhd-d2d5be27b09faee1481a763ce25e7b95460a46c9.zip
Add clkgen-config, usrp-e-i2c and usrp-e-spi to the installed utils.
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 6515048eb..ff0ca895a 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -27,18 +27,30 @@ TARGET_LINK_LIBRARIES(uhd_usrp_probe uhd)
ADD_EXECUTABLE(fpga-downloader fpga-downloader.cpp)
TARGET_LINK_LIBRARIES(fpga-downloader)
+ADD_EXECUTABLE(clkgen-config clkgen-config.cpp)
+TARGET_LINK_LIBRARIES(clkgen-config)
+
ADD_EXECUTABLE(usrp-e-loopback usrp-e-loopback.c)
TARGET_LINK_LIBRARIES(usrp-e-loopback pthread)
ADD_EXECUTABLE(usrp-e-debug-pins usrp-e-debug-pins.c)
TARGET_LINK_LIBRARIES(usrp-e-debug-pins)
+ADD_EXECUTABLE(usrp-e-i2c usrp-e-i2c.c)
+TARGET_LINK_LIBRARIES(usrp-e-i2c)
+
+ADD_EXECUTABLE(usrp-e-spi usrp-e-spi.c)
+TARGET_LINK_LIBRARIES(usrp-e-spi)
+
INSTALL(TARGETS
uhd_find_devices
uhd_usrp_probe
fpga-downloader
usrp-e-loopback
usrp-e-debug-pins
+ usrp-e-spi
+ usrp-e-i2c
+ clkgen-config
RUNTIME DESTINATION ${RUNTIME_DIR}
)