aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Koo <steven.koo@ni.com>2021-03-10 12:21:33 -0600
committerAaron Rossetto <aaron.rossetto@ni.com>2021-03-19 15:40:09 -0500
commit9aafc0ace2272746d708dcac6e5daaa50b7da4c7 (patch)
treee26c85e334ca523312719bdae382dda8c18a90c7 /host/utils/CMakeLists.txt
parentada6a4e46770d22d528b2b6fbc2bdd71e5e3064d (diff)
downloaduhd-9aafc0ace2272746d708dcac6e5daaa50b7da4c7.tar.gz
uhd-9aafc0ace2272746d708dcac6e5daaa50b7da4c7.tar.bz2
uhd-9aafc0ace2272746d708dcac6e5daaa50b7da4c7.zip
uhd: enable vcpkg support on windows
vcpkg can be used for the Windows C++ dependencies for uhd with this commit. To use vcpkg on Windows: 1) Copy the custom triplets in host/cmake/vcpkg/ to the vcpkg/triplets/ folder. 2) Install boost and libusb for the custom triplet "vcpkg install libusb:uhd-x64-windows-static-md boost:uhd-x64-windows-static-md" 3) Call CMake with vcpkg toolchain file flags: -DVCPKG_TARGET_TRIPLET=uhd-x64-windows-static-md -DCMAKE_TOOLCHAIN_FILE=%VCPKG_INSTALL_DIR%/scripts/buildsystems/vcpkg.cmake -G "Visual Studio 16 2019" -A x64 Replace the -G with the installed version of Visual Studio and matching architecture. Then build normally by running vcvarsall.bat and msbuild. Signed-off-by: Steven Koo <steven.koo@ni.com>
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 4bbcd252b..ab7d645f4 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -53,6 +53,7 @@ set(util_share_sources_py
uhd_power_cal.py
)
if(ENABLE_USB)
+ find_package(LIBUSB)
list(APPEND util_share_sources
fx2_init_eeprom.cpp
)