aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorSugandha Gupta <sugandha.gupta@ettus.com>2019-01-25 11:34:47 -0800
committerBrent Stapleton <brent.stapleton@ettus.com>2019-05-01 15:17:23 -0700
commit178b35569b1a25180a80a23b945b10b04c9f10f5 (patch)
tree3adb6f78ebd148867a50526c60fe7bf9694a4a72 /host/utils/CMakeLists.txt
parent8a400f6a30942c9d6d3596f6989720eb4cff058b (diff)
downloaduhd-178b35569b1a25180a80a23b945b10b04c9f10f5.tar.gz
uhd-178b35569b1a25180a80a23b945b10b04c9f10f5.tar.bz2
uhd-178b35569b1a25180a80a23b945b10b04c9f10f5.zip
e310/e320: Move E310 to MPM architecture and refactor
- Turns the E310 into an MPM device (like N3xx, E320) - Factor out common code between E320 and E310, maximize sharing between the two devices - Remove all pre-MPM E310 code that is no longer needed - Modify MPM to remove all existing overlays before applying new ones (this is necessary to enable idle image mode for E310) Co-authored-by: Virendra Kakade <virendra.kakade@ni.com> Signed-off-by: Virendra Kakade <virendra.kakade@ni.com>
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 4e8d8e5f0..58eb842e1 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -18,13 +18,6 @@ set(util_runtime_sources
uhd_cal_tx_iq_balance.cpp
)
-find_package(UDev)
-if(ENABLE_E300 AND NOT E300_FORCE_NETWORK)
- if(UDEV_FOUND)
- list(APPEND util_runtime_sources usrp_e3x0_network_mode.cpp)
- endif(UDEV_FOUND)
-endif(ENABLE_E300 AND NOT E300_FORCE_NETWORK)
-
#for each source: build an executable and install
foreach(util_source ${util_runtime_sources})
get_filename_component(util_name ${util_source} NAME_WE)