aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/x300/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-12-02 23:06:39 -0800
committerBrent Stapleton <brent.stapleton@ettus.com>2019-12-20 16:32:22 -0800
commit4547f2de85f0d8b258a89cea71af774fce8616b7 (patch)
treed1239e074c5a35b449638a34aa3a6f74a53adfbb /host/lib/usrp/x300/CMakeLists.txt
parent4e38eef817813c1bbd8a9cf972e4cf0134d24308 (diff)
downloaduhd-4547f2de85f0d8b258a89cea71af774fce8616b7.tar.gz
uhd-4547f2de85f0d8b258a89cea71af774fce8616b7.tar.bz2
uhd-4547f2de85f0d8b258a89cea71af774fce8616b7.zip
x300,mpmd: Enable DPDK
x300: - Remove obsolete variables from x300_eth_mgr and X300 motherboard components - Added some documentation / comments - Use constrained device args in more places - Enables the use of use_dpdk=1 - Switches between regular (kernel-based) and DPDK UDP mpmd: - Merge link_if_ctrl for udp and dpdk_udp - Update cmake options
Diffstat (limited to 'host/lib/usrp/x300/CMakeLists.txt')
-rw-r--r--host/lib/usrp/x300/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/host/lib/usrp/x300/CMakeLists.txt b/host/lib/usrp/x300/CMakeLists.txt
index 1bd71dab4..b00ee357c 100644
--- a/host/lib/usrp/x300/CMakeLists.txt
+++ b/host/lib/usrp/x300/CMakeLists.txt
@@ -35,4 +35,8 @@ if(ENABLE_X300)
${CMAKE_CURRENT_SOURCE_DIR}/x300_prop_tree.cpp
${CMAKE_CURRENT_SOURCE_DIR}/cdecode.c
)
+
+ if(ENABLE_DPDK)
+ add_definitions(-DHAVE_DPDK)
+ endif(ENABLE_DPDK)
endif(ENABLE_X300)