aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/include/CMakeLists.txt
diff options
context:
space:
mode:
authorLane Kolbly <lane.kolbly@ni.com>2021-01-06 11:34:05 -0600
committerAaron Rossetto <aaron.rossetto@ni.com>2021-01-11 12:23:24 -0600
commitc9b35e3b7107ab82c0e3978b7cbfd76ba98e2407 (patch)
tree3e161a882f8005baf04b3a802dc7636a579643e2 /host/lib/include/CMakeLists.txt
parent7f765f4f2be719473ee329c00f7125a785057deb (diff)
downloaduhd-c9b35e3b7107ab82c0e3978b7cbfd76ba98e2407.tar.gz
uhd-c9b35e3b7107ab82c0e3978b7cbfd76ba98e2407.tar.bz2
uhd-c9b35e3b7107ab82c0e3978b7cbfd76ba98e2407.zip
Create C++ wrappers for MPM RPC calls
This gives us type-safety, as well as allowing us to create unit tests for RFNoC radio_controls without having to create actual RPC servers and clients in the unit tests. This change also fixes a bug in mpmd_mb_controller::set_sync_source, where it was calling the wrong MPM function.
Diffstat (limited to 'host/lib/include/CMakeLists.txt')
-rw-r--r--host/lib/include/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/host/lib/include/CMakeLists.txt b/host/lib/include/CMakeLists.txt
index fc1a6c4d5..d2ecd88ee 100644
--- a/host/lib/include/CMakeLists.txt
+++ b/host/lib/include/CMakeLists.txt
@@ -5,4 +5,9 @@
#
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+LIBUHD_PYTHON_GEN_SOURCE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/uhdlib/usrp/common/rpc.py
+ ${CMAKE_CURRENT_BINARY_DIR}/uhdlib/usrp/common/rpc.hpp
+)