aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/deps/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2020-03-03 10:40:21 -0800
committerAaron Rossetto <aaron.rossetto@ni.com>2020-03-18 12:53:00 -0500
commitc755531eac46470e99568adfb62c4fbbc6e860d7 (patch)
tree0a730126e593d6f8aa3591e647d55ff251b98cec /host/lib/deps/CMakeLists.txt
parent3f1554f1a5a71190e2105354b8f6a8faa3347124 (diff)
downloaduhd-c755531eac46470e99568adfb62c4fbbc6e860d7.tar.gz
uhd-c755531eac46470e99568adfb62c4fbbc6e860d7.tar.bz2
uhd-c755531eac46470e99568adfb62c4fbbc6e860d7.zip
lib: deps: Add FlatBuffers 1.11.0 header files
FlatBuffers is used to (de-)serialize calibration data. For most use cases, only a few headers are required, so we provide them with UHD instead of requiring all UHD users to install their own version of FlatBuffers. This adds the headers to host/lib/deps, and updates the Debian copyright file appropriately.
Diffstat (limited to 'host/lib/deps/CMakeLists.txt')
-rw-r--r--host/lib/deps/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/host/lib/deps/CMakeLists.txt b/host/lib/deps/CMakeLists.txt
index e3dc76ee4..f6acc8543 100644
--- a/host/lib/deps/CMakeLists.txt
+++ b/host/lib/deps/CMakeLists.txt
@@ -1,5 +1,6 @@
#
# Copyright 2017 Ettus Research, a National Instruments Company
+# Copyright 2020 Ettus Research, a National Instruments Brand
#
# SPDX-License-Identifier: GPL-3.0-or-later
#
@@ -10,3 +11,4 @@ endif()
if(ENABLE_PYTHON_API)
add_subdirectory(pybind11)
endif()
+add_subdirectory(flatbuffers)