aboutsummaryrefslogtreecommitdiffstats
path: root/fpga/usrp3/sim/packages/Makefile.srcs
diff options
context:
space:
mode:
authorWade Fife <wade.fife@ettus.com>2021-07-06 18:53:14 -0500
committerWade Fife <wade.fife@ettus.com>2021-08-08 14:59:26 -0500
commitda4202e6f74796603072aa14544581604e81df02 (patch)
treeb5f568ed1959915d85c312188fd5546cd4b17b80 /fpga/usrp3/sim/packages/Makefile.srcs
parent8edd13e6eba61ef2bfd96c7dc88b2642decbaa7a (diff)
downloaduhd-da4202e6f74796603072aa14544581604e81df02.tar.gz
uhd-da4202e6f74796603072aa14544581604e81df02.tar.bz2
uhd-da4202e6f74796603072aa14544581604e81df02.zip
fpga: sim: Add PkgComplex, PkgMath, and PkgRandom
PkgComplex adds functions for doing complex arithmetic in SystemVerilog simulation. PkgMath provides mathematical operations and constants that aren't built into SystemVerilog, such as a constant for pi and the function round(). PkgRandom adds randomization functions beyond what standard Verilog supports but that don't require any special licenses or simulators.
Diffstat (limited to 'fpga/usrp3/sim/packages/Makefile.srcs')
-rw-r--r--fpga/usrp3/sim/packages/Makefile.srcs11
1 files changed, 11 insertions, 0 deletions
diff --git a/fpga/usrp3/sim/packages/Makefile.srcs b/fpga/usrp3/sim/packages/Makefile.srcs
new file mode 100644
index 000000000..4f87f3615
--- /dev/null
+++ b/fpga/usrp3/sim/packages/Makefile.srcs
@@ -0,0 +1,11 @@
+#
+# Copyright 2021 Ettus Research, A National Instruments Brand
+#
+# SPDX-License-Identifier: LGPL-3.0-or-later
+#
+
+SIM_PACKAGES_SRCS = $(abspath $(addprefix $(BASE_DIR)/../sim/packages/, \
+PkgMath.sv \
+PkgComplex.sv \
+PkgRandom.sv \
+))