aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2022-01-09 20:02:59 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2022-01-09 20:02:59 +0100
commit36276e45cc3dbca2e954515bd7b6b3b4498ddbb2 (patch)
tree4ec57160a6b6ec14974e44b5beabf8103907aa1e /CMakeLists.txt
parent2cf0eaffddab2457fc81d672599c0f58eb6950f9 (diff)
parenta0e7a58447006cdb1e10f781323c88bd08e66eea (diff)
downloadosmo-fl2k-36276e45cc3dbca2e954515bd7b6b3b4498ddbb2.tar.gz
osmo-fl2k-36276e45cc3dbca2e954515bd7b6b3b4498ddbb2.tar.bz2
osmo-fl2k-36276e45cc3dbca2e954515bd7b6b3b4498ddbb2.zip
Merge branch 'iq' into interleaved_rg
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5fb110f..84bc55d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,11 @@ project(libosmo-fl2k C)
include(GNUInstallDirs)
+# CMP0075 Include file check macros honor CMAKE_REQUIRED_LIBRARIES
+if(POLICY CMP0075)
+ cmake_policy(SET CMP0075 NEW)
+endif()
+
#select the release build type by default to get optimization flags
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")