aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2022-01-09 13:56:30 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2022-01-09 13:56:30 +0100
commita0e7a58447006cdb1e10f781323c88bd08e66eea (patch)
tree23f5dc6ae6141e4630812fece0f4cb5eb8b54d41 /CMakeLists.txt
parent3387a704bea2cb33ec389b7276ef7c293701fe5e (diff)
parent197f421c98f929d4266a09bc9d667b7869e09c27 (diff)
downloadosmo-fl2k-a0e7a58447006cdb1e10f781323c88bd08e66eea.tar.gz
osmo-fl2k-a0e7a58447006cdb1e10f781323c88bd08e66eea.tar.bz2
osmo-fl2k-a0e7a58447006cdb1e10f781323c88bd08e66eea.zip
Merge remote-tracking branch 'upstream/master' into iq
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5fb110f..84bc55d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,11 @@ project(libosmo-fl2k C)
include(GNUInstallDirs)
+# CMP0075 Include file check macros honor CMAKE_REQUIRED_LIBRARIES
+if(POLICY CMP0075)
+ cmake_policy(SET CMP0075 NEW)
+endif()
+
#select the release build type by default to get optimization flags
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")