aboutsummaryrefslogtreecommitdiffstats
path: root/tools/dissectors/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/dissectors/CMakeLists.txt')
-rw-r--r--tools/dissectors/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/dissectors/CMakeLists.txt b/tools/dissectors/CMakeLists.txt
index 6d835aa48..99eb51f76 100644
--- a/tools/dissectors/CMakeLists.txt
+++ b/tools/dissectors/CMakeLists.txt
@@ -116,6 +116,11 @@ WS_REGISTER_COMPONENT("RFNoC" ENABLE_RFNOC ON "" OFF ON)
WS_REGISTER_COMPONENT("Octoclock" ENABLE_OCTOCLOCK ON "" OFF OFF)
WS_REGISTER_COMPONENT("ZPU" ENABLE_ZPU ON "" OFF OFF)
+if(NOT DEFINED RFNOC_CHDR_WIDTH)
+ set(RFNOC_CHDR_WIDTH 64)
+endif()
+add_definitions(-DRFNOC_CHDR_WIDTH=${RFNOC_CHDR_WIDTH})
+
if(ENABLE_RFNOC)
add_subdirectory(epan/rfnoc)
endif(ENABLE_RFNOC)