aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/python/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mpm/python/tests/CMakeLists.txt')
-rwxr-xr-xmpm/python/tests/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/mpm/python/tests/CMakeLists.txt b/mpm/python/tests/CMakeLists.txt
new file mode 100755
index 000000000..26dcad40a
--- /dev/null
+++ b/mpm/python/tests/CMakeLists.txt
@@ -0,0 +1,14 @@
+#
+# Copyright 2019 Ettus Research, a National Instruments Brand
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+add_test(
+ NAME mpm_unit_tests
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/run_unit_tests.py ${MPM_DEVICE}
+)