aboutsummaryrefslogtreecommitdiffstats
path: root/images/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'images/CMakeLists.txt')
-rw-r--r--images/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/images/CMakeLists.txt b/images/CMakeLists.txt
index 75cb4c9d3..ee8146f3a 100644
--- a/images/CMakeLists.txt
+++ b/images/CMakeLists.txt
@@ -15,14 +15,13 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-PROJECT(UHD-images NONE)
-
########################################################################
-# Config Files (include order is important)
+# Setup Project
########################################################################
-INCLUDE(${CMAKE_SOURCE_DIR}/../host/config/Python.cmake)
-INCLUDE(${CMAKE_SOURCE_DIR}/../host/config/Version.cmake)
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+PROJECT(UHD-images NONE)
+LIST(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/../host/Modules)
+INCLUDE(UHDVersion) #sets version variables (used below)
########################################################################
# Setup CPack