aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/rfnoc/templates/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/utils/rfnoc/templates/CMakeLists.txt')
-rw-r--r--host/utils/rfnoc/templates/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/host/utils/rfnoc/templates/CMakeLists.txt b/host/utils/rfnoc/templates/CMakeLists.txt
new file mode 100644
index 000000000..88c5e3bd4
--- /dev/null
+++ b/host/utils/rfnoc/templates/CMakeLists.txt
@@ -0,0 +1,16 @@
+#
+# Copyright 2019 Ettus Research, A National Instrument Brand
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+set(RFNOC_PKG_FILES ${RFNOC_PKG_FILES})
+set(RFNOC_PKG_TOP_FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/rfnoc_image_core.v.mako
+)
+list(APPEND RFNOC_PKG_FILES ${RFNOC_PKG_TOP_FILES})
+add_subdirectory(modules)
+set(RFNOC_PKG_FILES ${RFNOC_PKG_FILES} PARENT_SCOPE)