aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 9f92b244c..5f8309587 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -127,6 +127,14 @@ CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/uhd_images_downloader.py.in
${CMAKE_CURRENT_BINARY_DIR}/uhd_images_downloader.py
@ONLY)
+# TODO: FIXME when know how.
+# This is a hack to force cmake regenerate uhd_images_downloader.py
+# whenever manifest.txt file changed.
+CONFIGURE_FILE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../images/manifest.txt
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../images/manifest.txt
+COPYONLY)
+
UHD_INSTALL(PROGRAMS
${CMAKE_CURRENT_BINARY_DIR}/uhd_images_downloader.py
DESTINATION ${PKG_LIB_DIR}/utils