aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/tests/common/CMakeLists.txt')
-rw-r--r--host/tests/common/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/host/tests/common/CMakeLists.txt b/host/tests/common/CMakeLists.txt
new file mode 100644
index 000000000..91a70dfae
--- /dev/null
+++ b/host/tests/common/CMakeLists.txt
@@ -0,0 +1,15 @@
+#
+# Copyright 2018 Ettus Research, a National Instruments Company
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+########################################################################
+# Build uhd_test static lib
+########################################################################
+INCLUDE_DIRECTORIES("${CMAKE_SOURCE_DIR}/lib/include")
+ADD_LIBRARY(uhd_test ${CMAKE_CURRENT_SOURCE_DIR}/mock_ctrl_iface_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/mock_zero_copy.cpp
+ ${CMAKE_SOURCE_DIR}/lib/rfnoc/graph_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/rfnoc/async_msg_handler.cpp
+) \ No newline at end of file