aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 47ca5b79f..6626b9c3a 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -32,7 +32,6 @@ set(test_sources
constrained_device_args_test.cpp
convert_test.cpp
dict_test.cpp
- discoverable_feature_test.cpp
eeprom_utils_test.cpp
error_test.cpp
fp_compare_delta_test.cpp
@@ -339,6 +338,12 @@ UHD_ADD_NONAPI_TEST(
${CMAKE_SOURCE_DIR}/lib/usrp/common/pwr_cal_mgr.cpp
)
+UHD_ADD_NONAPI_TEST(
+ TARGET "discoverable_feature_test.cpp"
+ EXTRA_SOURCES
+ ${CMAKE_SOURCE_DIR}/lib/features/discoverable_feature_registry.cpp
+)
+
########################################################################
# demo of a loadable module
########################################################################