aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 643efba34..ea069410b 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -59,10 +59,6 @@ set(test_sources
tx_streamer_test.cpp
)
-set(benchmark_sources
- packet_handler_benchmark.cpp
-)
-
#turn each test cpp file into an executable with an int main() function
add_definitions(-DBOOST_TEST_DYN_LINK -DBOOST_TEST_MAIN)
@@ -121,7 +117,7 @@ macro(UHD_ADD_NONAPI_TEST)
get_filename_component(test_name ${test_TARGET} NAME_WE)
include_directories(${test_INCLUDE_DIRS})
add_executable(${test_name} ${test_TARGET} ${test_EXTRA_SOURCES})
- target_link_libraries(${test_name} uhd ${Boost_LIBRARIES})
+ target_link_libraries(${test_name} uhd uhd_test ${Boost_LIBRARIES})
if(NOT ${test_NOAUTORUN})
UHD_ADD_TEST(${test_name} ${test_name})
endif(NOT ${test_NOAUTORUN})
@@ -190,6 +186,11 @@ UHD_ADD_NONAPI_TEST(
)
UHD_ADD_NONAPI_TEST(
+ TARGET "packet_handler_benchmark.cpp"
+ NOAUTORUN
+)
+
+UHD_ADD_NONAPI_TEST(
TARGET "config_parser_test.cpp"
EXTRA_SOURCES ${CMAKE_SOURCE_DIR}/lib/utils/config_parser.cpp
)