aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 821b2eb9e..f08fe669b 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -50,5 +50,7 @@ ENDFOREACH(test_source)
########################################################################
# demo of a loadable module
########################################################################
-ADD_LIBRARY(module_test MODULE module_test.cpp)
-TARGET_LINK_LIBRARIES(module_test uhd)
+IF(MSVC OR APPLE OR LINUX)
+ ADD_LIBRARY(module_test MODULE module_test.cpp)
+ TARGET_LINK_LIBRARIES(module_test uhd)
+ENDIF()