aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 88b673bb1..c918cc6bb 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -241,6 +241,16 @@ UHD_ADD_NONAPI_TEST(
${CMAKE_SOURCE_DIR}/lib/rfnoc/client_zero.cpp
)
+UHD_ADD_NONAPI_TEST(
+ TARGET rfnoc_blocks_test.cpp
+ EXTRA_SOURCES
+ ${CMAKE_SOURCE_DIR}/lib/rfnoc/noc_block_base.cpp
+ ${CMAKE_SOURCE_DIR}/lib/rfnoc/block_id.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/compat_check.cpp
+ ${CMAKE_SOURCE_DIR}/lib/rfnoc/ddc_block_control.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/cores/dsp_core_utils.cpp
+)
+
########################################################################
# demo of a loadable module
########################################################################