aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/utils/CMakeLists.txt')
-rw-r--r--host/lib/utils/CMakeLists.txt62
1 files changed, 0 insertions, 62 deletions
diff --git a/host/lib/utils/CMakeLists.txt b/host/lib/utils/CMakeLists.txt
index 5c4478909..4369a8f11 100644
--- a/host/lib/utils/CMakeLists.txt
+++ b/host/lib/utils/CMakeLists.txt
@@ -132,68 +132,6 @@ set_source_files_properties(
)
########################################################################
-# Setup defines for high resolution timing
-########################################################################
-message(STATUS "")
-message(STATUS "Configuring high resolution timing...")
-include(CheckCXXSourceCompiles)
-
-set(CMAKE_REQUIRED_LIBRARIES -lrt)
-CHECK_CXX_SOURCE_COMPILES("
- #include <ctime>
- int main(){
- timespec ts;
- return clock_gettime(CLOCK_MONOTONIC, &ts);
- }
- " HAVE_CLOCK_GETTIME
-)
-set(CMAKE_REQUIRED_LIBRARIES)
-
-include(CheckCXXSourceCompiles)
-CHECK_CXX_SOURCE_COMPILES("
- #include <mach/mach_time.h>
- int main(){
- mach_timebase_info_data_t info;
- mach_timebase_info(&info);
- mach_absolute_time();
- return 0;
- }
- " HAVE_MACH_ABSOLUTE_TIME
-)
-
-CHECK_CXX_SOURCE_COMPILES("
- #include <Windows.h>
- int main(){
- LARGE_INTEGER value;
- QueryPerformanceCounter(&value);
- QueryPerformanceFrequency(&value);
- return 0;
- }
- " HAVE_QUERY_PERFORMANCE_COUNTER
-)
-
-
-if(HAVE_CLOCK_GETTIME)
- message(STATUS " High resolution timing supported through clock_gettime.")
- set(SYSTEM_TIME_DEFS HAVE_CLOCK_GETTIME)
- LIBUHD_APPEND_LIBS("-lrt")
-elseif(HAVE_MACH_ABSOLUTE_TIME)
- message(STATUS " High resolution timing supported through mach_absolute_time.")
- set(SYSTEM_TIME_DEFS HAVE_MACH_ABSOLUTE_TIME)
-elseif(HAVE_QUERY_PERFORMANCE_COUNTER)
- message(STATUS " High resolution timing supported through QueryPerformanceCounter.")
- set(SYSTEM_TIME_DEFS HAVE_QUERY_PERFORMANCE_COUNTER)
-else()
- message(STATUS " High resolution timing supported though microsec_clock.")
- set(SYSTEM_TIME_DEFS HAVE_MICROSEC_CLOCK)
-endif()
-
-set_source_files_properties(
- ${CMAKE_CURRENT_SOURCE_DIR}/system_time.cpp
- PROPERTIES COMPILE_DEFINITIONS "${SYSTEM_TIME_DEFS}"
-)
-
-########################################################################
# Setup defines for module loading
########################################################################
message(STATUS "")