aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp_clock/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/usrp_clock/CMakeLists.txt')
-rw-r--r--host/lib/usrp_clock/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/host/lib/usrp_clock/CMakeLists.txt b/host/lib/usrp_clock/CMakeLists.txt
new file mode 100644
index 000000000..8a58aa9ac
--- /dev/null
+++ b/host/lib/usrp_clock/CMakeLists.txt
@@ -0,0 +1,26 @@
+#
+# Copyright 2011-2014 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/multi_usrp_clock.cpp
+)
+
+INCLUDE_SUBDIRECTORY(octoclock)