aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/x400/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/usrp/x400/CMakeLists.txt')
-rw-r--r--host/lib/usrp/x400/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/host/lib/usrp/x400/CMakeLists.txt b/host/lib/usrp/x400/CMakeLists.txt
new file mode 100644
index 000000000..b3efe3b60
--- /dev/null
+++ b/host/lib/usrp/x400/CMakeLists.txt
@@ -0,0 +1,20 @@
+#
+# Copyright 2020 Ettus Research, a National Instruments Brand
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/adc_self_calibration.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/x400_radio_control.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/x400_rfdc_control.cpp
+)
+
+if(ENABLE_DPDK)
+ include_directories(${DPDK_INCLUDE_DIRS})
+ add_definitions(-DHAVE_DPDK)
+endif(ENABLE_DPDK)