aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/usrp_e/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/usrp/usrp_e/CMakeLists.txt')
-rw-r--r--host/lib/usrp/usrp_e/CMakeLists.txt28
1 files changed, 18 insertions, 10 deletions
diff --git a/host/lib/usrp/usrp_e/CMakeLists.txt b/host/lib/usrp/usrp_e/CMakeLists.txt
index 2eff3147d..c25b2cba4 100644
--- a/host/lib/usrp/usrp_e/CMakeLists.txt
+++ b/host/lib/usrp/usrp_e/CMakeLists.txt
@@ -17,18 +17,26 @@
#This file will be included by cmake, use absolute paths!
+########################################################################
+# Helpful macro to check for required headers
+########################################################################
+INCLUDE(CheckIncludeFileCXX)
+SET(HAVE_USRP_E_REQUIRED_HEADERS TRUE)
+MACRO(USRP_E_REQUIRE_HEADER header variable)
+ CHECK_INCLUDE_FILE_CXX(${header} ${variable})
+ IF(NOT ${variable})
+ SET(HAVE_USRP_E_REQUIRED_HEADERS FALSE)
+ ENDIF(NOT ${variable})
+ENDMACRO(USRP_E_REQUIRE_HEADER)
+
+########################################################################
+# Conditionally configure the USRP-E support
+########################################################################
MESSAGE(STATUS "Configuring usrp-e support...")
-INCLUDE(CheckIncludeFiles)
-SET(usrp_e_required_headers
- linux/ioctl.h
- linux/spi/spidev.h
- linux/usrp_e.h
-)
-CHECK_INCLUDE_FILES(
- "${usrp_e_required_headers}"
- HAVE_USRP_E_REQUIRED_HEADERS
-)
+USRP_E_REQUIRE_HEADER(linux/ioctl.h HAVE_LINUX_IOCTL_H)
+USRP_E_REQUIRE_HEADER(linux/spi/spidev.h HAVE_LINUX_SPI_SPIDEV_H)
+USRP_E_REQUIRE_HEADER(linux/usrp_e.h HAVE_LINUX_USRP_E_H)
IF(HAVE_USRP_E_REQUIRED_HEADERS)
MESSAGE(STATUS " Building usrp-e support.")