aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/usrp_b100/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/usrp/usrp_b100/CMakeLists.txt')
-rw-r--r--host/lib/usrp/usrp_b100/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/host/lib/usrp/usrp_b100/CMakeLists.txt b/host/lib/usrp/usrp_b100/CMakeLists.txt
new file mode 100644
index 000000000..f83a10935
--- /dev/null
+++ b/host/lib/usrp/usrp_b100/CMakeLists.txt
@@ -0,0 +1,47 @@
+#
+# Copyright 2010-2011 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+########################################################################
+# Conditionally configure the B100 support
+########################################################################
+LIBUHD_REGISTER_COMPONENT("B100" ENABLE_B100 ON "ENABLE_LIBUHD;ENABLE_USB" OFF)
+
+IF(ENABLE_B100)
+ LIBUHD_APPEND_SOURCES(
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/clock_ctrl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/clock_ctrl.hpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/codec_ctrl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/codec_ctrl.hpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/codec_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/ctrl_packet.hpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/dboard_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/dboard_iface.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/dsp_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/io_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/mboard_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/b100_ctrl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/b100_ctrl.hpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/b100_iface.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/b100_iface.hpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/b100_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_b100/b100_impl.hpp
+ )
+ENDIF(ENABLE_B100)