aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/e300/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/usrp/e300/CMakeLists.txt')
-rw-r--r--host/lib/usrp/e300/CMakeLists.txt55
1 files changed, 55 insertions, 0 deletions
diff --git a/host/lib/usrp/e300/CMakeLists.txt b/host/lib/usrp/e300/CMakeLists.txt
new file mode 100644
index 000000000..9ee9b5521
--- /dev/null
+++ b/host/lib/usrp/e300/CMakeLists.txt
@@ -0,0 +1,55 @@
+#
+# Copyright 2013-2014 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+########################################################################
+# Conditionally configure the USRP-E300 support
+########################################################################
+find_package(UDev)
+
+LIBUHD_REGISTER_COMPONENT("E300" ENABLE_E300 OFF "ENABLE_LIBUHD" OFF)
+
+IF(ENABLE_E300)
+ LIST(APPEND E300_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_io_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_fifo_config.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_sysfs_hooks.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_network.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_global_regs.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_spi.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_sensor_manager.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_i2c.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_eeprom_manager.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_common.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_async_serial.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_ublox_control_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e300_remote_codec_ctrl.cpp
+ )
+ LIBUHD_APPEND_SOURCES(${E300_SOURCES})
+ IF(UDEV_FOUND)
+ INCLUDE_DIRECTORIES(${UDEV_INCLUDE_DIR})
+ LIBUHD_APPEND_LIBS(${UDEV_LIBS})
+ SET_SOURCE_FILES_PROPERTIES(
+ ${E300_SOURCES}
+ PROPERTIES COMPILE_DEFINITIONS "E300_NATIVE=1"
+ )
+ ENDIF(UDEV_FOUND)
+ENDIF(ENABLE_E300)