aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/dboard/rhodium/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/usrp/dboard/rhodium/CMakeLists.txt')
-rw-r--r--host/lib/usrp/dboard/rhodium/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/host/lib/usrp/dboard/rhodium/CMakeLists.txt b/host/lib/usrp/dboard/rhodium/CMakeLists.txt
new file mode 100644
index 000000000..617e4af58
--- /dev/null
+++ b/host/lib/usrp/dboard/rhodium/CMakeLists.txt
@@ -0,0 +1,18 @@
+#
+# Copyright 2018 Ettus Research, a National Instruments Company
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+IF(ENABLE_MPMD)
+ LIST(APPEND RHODIUM_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/rhodium_radio_ctrl_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/rhodium_radio_ctrl_init.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/rhodium_radio_ctrl_cpld.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/rhodium_radio_ctrl_lo.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/rhodium_bands.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/rhodium_cpld_ctrl.cpp
+ )
+ LIBUHD_APPEND_SOURCES(${RHODIUM_SOURCES})
+ENDIF(ENABLE_MPMD)
+