aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/dboard/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/usrp/dboard/CMakeLists.txt')
-rw-r--r--host/lib/usrp/dboard/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/host/lib/usrp/dboard/CMakeLists.txt b/host/lib/usrp/dboard/CMakeLists.txt
index 6bca04290..83bb0a96c 100644
--- a/host/lib/usrp/dboard/CMakeLists.txt
+++ b/host/lib/usrp/dboard/CMakeLists.txt
@@ -46,5 +46,9 @@ IF(ENABLE_X300)
)
ENDIF(ENABLE_X300)
-INCLUDE_SUBDIRECTORY(magnesium)
-INCLUDE_SUBDIRECTORY(eiscat)
+IF(ENABLE_N300)
+ INCLUDE_SUBDIRECTORY(magnesium)
+ENDIF(ENABLE_N300)
+IF(ENABLE_MPMD AND ENABLE_EISCAT)
+ INCLUDE_SUBDIRECTORY(eiscat)
+ENDIF(ENABLE_MPMD AND ENABLE_EISCAT)