aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/transport/nirio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/transport/nirio/CMakeLists.txt')
-rw-r--r--host/lib/transport/nirio/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/host/lib/transport/nirio/CMakeLists.txt b/host/lib/transport/nirio/CMakeLists.txt
index 6a33da6c5..5f12e91df 100644
--- a/host/lib/transport/nirio/CMakeLists.txt
+++ b/host/lib/transport/nirio/CMakeLists.txt
@@ -39,10 +39,8 @@ LIBUHD_APPEND_SOURCES(
IF(WIN32)
LIBUHD_APPEND_SOURCES(${CMAKE_CURRENT_SOURCE_DIR}/nirio_driver_iface_win.cpp)
-ELSE(WIN32)
- IF(APPLE)
- LIBUHD_APPEND_SOURCES(${CMAKE_CURRENT_SOURCE_DIR}/nirio_driver_iface_macos.cpp)
- ELSE(APPLE)
- LIBUHD_APPEND_SOURCES(${CMAKE_CURRENT_SOURCE_DIR}/nirio_driver_iface_linux.cpp)
- ENDIF(APPLE)
+ELSEIF(${CMAKE_SYSTEM_NAME} STREQUAL "Linux") #Built-in variable encompasses all UNIX-like systems
+ LIBUHD_APPEND_SOURCES(${CMAKE_CURRENT_SOURCE_DIR}/nirio_driver_iface_linux.cpp)
+ELSE()
+ LIBUHD_APPEND_SOURCES(${CMAKE_CURRENT_SOURCE_DIR}/nirio_driver_iface_unsupported.cpp)
ENDIF(WIN32)