aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/ic_reg_maps/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/ic_reg_maps/CMakeLists.txt')
-rw-r--r--host/lib/ic_reg_maps/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/host/lib/ic_reg_maps/CMakeLists.txt b/host/lib/ic_reg_maps/CMakeLists.txt
index 42ac4d051..039614c03 100644
--- a/host/lib/ic_reg_maps/CMakeLists.txt
+++ b/host/lib/ic_reg_maps/CMakeLists.txt
@@ -128,6 +128,11 @@ LIBUHD_PYTHON_GEN_SOURCE(
)
LIBUHD_PYTHON_GEN_SOURCE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/gen_lmx2572_regs.py
+ ${CMAKE_CURRENT_BINARY_DIR}/lmx2572_regs.hpp
+)
+
+LIBUHD_PYTHON_GEN_SOURCE(
${CMAKE_CURRENT_SOURCE_DIR}/gen_lmk04828_regs.py
${CMAKE_CURRENT_BINARY_DIR}/lmk04828_regs.hpp
)
@@ -142,4 +147,9 @@ LIBUHD_PYTHON_GEN_SOURCE(
${CMAKE_CURRENT_BINARY_DIR}/rhodium_cpld_regs.hpp
)
+LIBUHD_PYTHON_GEN_SOURCE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/gen_zbx_cpld_regs.py
+ ${CMAKE_CURRENT_BINARY_DIR}/zbx_cpld_regs.hpp
+ )
+
set(LIBUHD_PYTHON_GEN_SOURCE_DEPS)