aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt19
1 files changed, 13 insertions, 6 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 0483cd11c..b25ba38e2 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -60,12 +60,6 @@ SET(libuhd_sources
usrp/simple_usrp.cpp
usrp/dboard_manager.cpp
usrp/tune_helper.cpp
- usrp/usrp2/dboard_impl.cpp
- usrp/usrp2/dboard_interface.cpp
- usrp/usrp2/dsp_impl.cpp
- usrp/usrp2/io_impl.cpp
- usrp/usrp2/mboard_impl.cpp
- usrp/usrp2/usrp2_impl.cpp
)
########################################################################
@@ -98,6 +92,19 @@ UHD_PYTHON_GEN_SOURCE_FILE(
)
########################################################################
+# Add usrp2 sources
+########################################################################
+LIST(APPEND libuhd_sources
+ usrp/usrp2/clock_control.cpp
+ usrp/usrp2/dboard_impl.cpp
+ usrp/usrp2/dboard_interface.cpp
+ usrp/usrp2/dsp_impl.cpp
+ usrp/usrp2/io_impl.cpp
+ usrp/usrp2/mboard_impl.cpp
+ usrp/usrp2/usrp2_impl.cpp
+)
+
+########################################################################
# Conditionally add the udp sources
########################################################################
LIST(APPEND libuhd_sources