aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 5755a6c4c..321278db5 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -99,6 +99,10 @@ LIBUHD_APPEND_SOURCES(
# Add DLL resource file to Windows build
########################################################################
IF(MSVC)
+ SET(RC_TRIMMED_VERSION_PATCH TRIMMED_VERSION_PATCH)
+ IF(UHD_VERSION_DEVEL)
+ SET(RC_TRIMMED_VERSION_PATCH "999")
+ ENDIF(UHD_VERSION_DEVEL)
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/uhd.rc.in
${CMAKE_CURRENT_BINARY_DIR}/uhd.rc