aboutsummaryrefslogtreecommitdiffstats
path: root/host/include/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/include/CMakeLists.txt')
-rw-r--r--host/include/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/host/include/CMakeLists.txt b/host/include/CMakeLists.txt
index 780213918..8b1e6bc05 100644
--- a/host/include/CMakeLists.txt
+++ b/host/include/CMakeLists.txt
@@ -20,4 +20,11 @@ CONFIGURE_FILE(
${CMAKE_CURRENT_BINARY_DIR}/config.h
)
+IF(ENABLE_C_API)
+ UHD_INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/uhd.h
+ DESTINATION ${INCLUDE_DIR}
+ COMPONENT headers
+ )
+ENDIF(ENABLE_C_API)
+
ADD_SUBDIRECTORY(uhd)