aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/rfnoc-example/blocks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/examples/rfnoc-example/blocks/CMakeLists.txt')
-rw-r--r--host/examples/rfnoc-example/blocks/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/host/examples/rfnoc-example/blocks/CMakeLists.txt b/host/examples/rfnoc-example/blocks/CMakeLists.txt
new file mode 100644
index 000000000..046af2265
--- /dev/null
+++ b/host/examples/rfnoc-example/blocks/CMakeLists.txt
@@ -0,0 +1,17 @@
+#
+# Copyright 2019 Ettus Research, a National Instruments Brand
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+# Reminder: This won't auto-update when you add a file, you need to re-run CMake
+# to re-generate the glob. Or, you add the files directly into the install()
+# statement below.
+file(GLOB yml_files "*.yml")
+# List all header files here (UHD and GNU Radio)
+install(
+ FILES
+ ${yml_files}
+ DESTINATION ${PROJECT_DATA_DIR}/blocks
+ COMPONENT blocks
+)