aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
index a8873f8d3..3203cffc0 100644
--- a/host/examples/CMakeLists.txt
+++ b/host/examples/CMakeLists.txt
@@ -22,6 +22,12 @@ TARGET_LINK_LIBRARIES(benchmark_rx_rate uhd)
ADD_EXECUTABLE(rx_timed_samples rx_timed_samples.cpp)
TARGET_LINK_LIBRARIES(rx_timed_samples uhd)
+ADD_EXECUTABLE(rx_to_file rx_to_file.cpp)
+TARGET_LINK_LIBRARIES(rx_to_file uhd)
+
+ADD_EXECUTABLE(rx_to_udp rx_to_udp.cpp)
+TARGET_LINK_LIBRARIES(rx_to_udp uhd)
+
ADD_EXECUTABLE(test_async_messages test_async_messages.cpp)
TARGET_LINK_LIBRARIES(test_async_messages uhd)
@@ -31,6 +37,9 @@ TARGET_LINK_LIBRARIES(test_pps_input uhd)
ADD_EXECUTABLE(tx_timed_samples tx_timed_samples.cpp)
TARGET_LINK_LIBRARIES(tx_timed_samples uhd)
+ADD_EXECUTABLE(tx_from_file tx_from_file.cpp)
+TARGET_LINK_LIBRARIES(tx_from_file uhd)
+
ADD_EXECUTABLE(tx_waveforms tx_waveforms.cpp)
TARGET_LINK_LIBRARIES(tx_waveforms uhd)
@@ -40,6 +49,9 @@ INSTALL(TARGETS
test_async_messages
test_pps_input
tx_timed_samples
+ tx_from_file
+ rx_to_file
+ rx_to_udp
tx_waveforms
RUNTIME DESTINATION ${PKG_DATA_DIR}/examples
)