aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorPhilip Balister <philip@opensdr.com>2010-10-27 06:27:05 -0400
committerPhilip Balister <philip@opensdr.com>2010-10-27 06:27:05 -0400
commitfbdb002223f54bedbc7a4093494011c1b266fa75 (patch)
treec8ba9446f117893cb28c00b91f953b5339c71f5f /host/examples/CMakeLists.txt
parentdb0e3e574e9058ad51cacea91ccc42f0baed95fa (diff)
parentef8ed898cbc6cb6cd1994d2a8b090112f4f3a664 (diff)
downloaduhd-fbdb002223f54bedbc7a4093494011c1b266fa75.tar.gz
uhd-fbdb002223f54bedbc7a4093494011c1b266fa75.tar.bz2
uhd-fbdb002223f54bedbc7a4093494011c1b266fa75.zip
Merge branch 'master' of ettus.sourcerepo.com:ettus/uhdpriv into usrp_e
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
index 3b36f3e71..3203cffc0 100644
--- a/host/examples/CMakeLists.txt
+++ b/host/examples/CMakeLists.txt
@@ -55,3 +55,15 @@ INSTALL(TARGETS
tx_waveforms
RUNTIME DESTINATION ${PKG_DATA_DIR}/examples
)
+
+########################################################################
+# ASCII Art DFT - requires curses, so this part is optional
+########################################################################
+INCLUDE(FindCurses)
+
+IF(CURSES_FOUND)
+ INCLUDE_DIRECTORIES(${CURSES_INCLUDE_DIR})
+ ADD_EXECUTABLE(rx_ascii_art_dft rx_ascii_art_dft.cpp)
+ TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES})
+ INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_DATA_DIR}/examples)
+ENDIF(CURSES_FOUND)