aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/usrp3/x300/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'firmware/usrp3/x300/CMakeLists.txt')
-rw-r--r--firmware/usrp3/x300/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/firmware/usrp3/x300/CMakeLists.txt b/firmware/usrp3/x300/CMakeLists.txt
new file mode 100644
index 000000000..5e6134885
--- /dev/null
+++ b/firmware/usrp3/x300/CMakeLists.txt
@@ -0,0 +1,36 @@
+#
+# Copyright 2010-2014 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_SOURCE_DIR}/../../host/lib/usrp/x300)
+
+list(APPEND x300_sources x300_init.c x300_main.c)
+
+########################################################################
+set(GEN_OUTPUTS_BIN_SIZE 0x7fff)
+SET(CMAKE_C_FLAGS_DEBUG -DX300_DEBUG_UART)
+
+add_executable(x300_main.elf ${x300_sources})
+target_link_libraries(x300_main.elf usrp3fw)
+GEN_OUTPUTS(x300_main.elf x300)
+
+INSTALL(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/x300_main.bin
+ DESTINATION share/uhd/images
+ RENAME usrp_x300_fw.bin
+)