aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/fx2/b100/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'firmware/fx2/b100/CMakeLists.txt')
-rw-r--r--firmware/fx2/b100/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/firmware/fx2/b100/CMakeLists.txt b/firmware/fx2/b100/CMakeLists.txt
index 438aa9207..18bc2080a 100644
--- a/firmware/fx2/b100/CMakeLists.txt
+++ b/firmware/fx2/b100/CMakeLists.txt
@@ -84,5 +84,11 @@ add_custom_target(b100_eeprom ALL
COMMAND ${PYTHON_EXECUTABLE} ${BUILD_EEPROM} -r2 b100_boot.bin b100_eeprom.bin
)
+add_custom_target(b100_eeprom_header ALL
+ DEPENDS b100_eeprom
+ COMMAND xxd -i b100_eeprom.bin ${CMAKE_SOURCE_DIR}/../../host/utils/b100_eeprom.h
+ COMMAND sed -i 's/char/const char/' ${CMAKE_SOURCE_DIR}/../../host/utils/b100_eeprom.h
+)
+
add_executable(b100_boot ${eeprom1p_sources})
target_link_libraries(b100_boot libb100)