aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gr-usrptest/python/setup.py
diff options
context:
space:
mode:
authorAndrej Rode <andrej.rode@ettus.com>2016-10-19 16:41:59 -0700
committerMartin Braun <martin.braun@ettus.com>2017-05-26 16:01:37 -0700
commit4b7b35570c13766ed575f69d79bf1ded954b6886 (patch)
treea07e385db0e3e6adca71a2b3c817993e0b2c8422 /tools/gr-usrptest/python/setup.py
parent76e9e6393fe1d5a0ccc9e05deb431694921850ec (diff)
downloaduhd-4b7b35570c13766ed575f69d79bf1ded954b6886.tar.gz
uhd-4b7b35570c13766ed575f69d79bf1ded954b6886.tar.bz2
uhd-4b7b35570c13766ed575f69d79bf1ded954b6886.zip
gr-usrptest: add LabVIEW remote control capability
- require modules labview_automation and hoplite for RTS python module - new python module: labview_control
Diffstat (limited to 'tools/gr-usrptest/python/setup.py')
-rw-r--r--tools/gr-usrptest/python/setup.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/gr-usrptest/python/setup.py b/tools/gr-usrptest/python/setup.py
new file mode 100644
index 000000000..6969f413d
--- /dev/null
+++ b/tools/gr-usrptest/python/setup.py
@@ -0,0 +1,13 @@
+#!/usr/bin/env python
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+
+setup(name='urptest_automation',
+ version='0.0.1',
+ description='usrptest integration into RTS and Labview',
+ packages=['usrptest_automation'],
+ install_requires=['labview-automation>=15.0.0.dev1','hoplite>=15.0.0.dev1']
+ )