aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gr-usrptest/python/labview_control/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrej Rode <andrej.rode@ettus.com>2016-10-19 16:41:59 -0700
committerMartin Braun <martin.braun@ettus.com>2017-05-26 16:01:37 -0700
commit4b7b35570c13766ed575f69d79bf1ded954b6886 (patch)
treea07e385db0e3e6adca71a2b3c817993e0b2c8422 /tools/gr-usrptest/python/labview_control/CMakeLists.txt
parent76e9e6393fe1d5a0ccc9e05deb431694921850ec (diff)
downloaduhd-4b7b35570c13766ed575f69d79bf1ded954b6886.tar.gz
uhd-4b7b35570c13766ed575f69d79bf1ded954b6886.tar.bz2
uhd-4b7b35570c13766ed575f69d79bf1ded954b6886.zip
gr-usrptest: add LabVIEW remote control capability
- require modules labview_automation and hoplite for RTS python module - new python module: labview_control
Diffstat (limited to 'tools/gr-usrptest/python/labview_control/CMakeLists.txt')
-rw-r--r--tools/gr-usrptest/python/labview_control/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/gr-usrptest/python/labview_control/CMakeLists.txt b/tools/gr-usrptest/python/labview_control/CMakeLists.txt
new file mode 100644
index 000000000..924df5479
--- /dev/null
+++ b/tools/gr-usrptest/python/labview_control/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Install python sources
+########################################################################
+GR_PYTHON_INSTALL(
+ FILES
+ __init__.py
+ lv_control.py DESTINATION ${GR_PYTHON_DIR}/usrptest/labview_control
+)
+