aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-01-25 16:07:07 -0800
committerJosh Blum <josh@joshknows.com>2010-01-25 16:07:07 -0800
commit998aebf83c2796fdfabc2efd804ca14103adcaaf (patch)
tree7e3675ffc14e41e390369fdeca4b9d7643ae6834 /test/Makefile.am
parent069a7ce0570001ea3d9512a11d238ea4d6773f1d (diff)
downloaduhd-998aebf83c2796fdfabc2efd804ca14103adcaaf.tar.gz
uhd-998aebf83c2796fdfabc2efd804ca14103adcaaf.tar.bz2
uhd-998aebf83c2796fdfabc2efd804ca14103adcaaf.zip
Various tweaks, switched to boost unit testing.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 0fbb18bf8..46b1de0e6 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -6,7 +6,7 @@ include $(top_srcdir)/Makefile.common
SUBDIRS =
-if HAVE_CPPUNIT
+if HAVE_UNIT_TEST
AM_CPPFLAGS = \
$(GENERAL_CPPFLAGS) \
@@ -14,15 +14,15 @@ AM_CPPFLAGS = \
LDADD = \
$(GENERAL_LDDFLAGS) \
- $(USRP_UHD_LA) \
- $(CPPUNIT_LIBS)
+ $(BOOST_UNIT_TEST_FRAMEWORK_LIB) \
+ $(USRP_UHD_LA)
-noinst_PROGRAMS = cppunit_test
+noinst_PROGRAMS = main_test
-cppunit_test_SOURCES = \
+main_test_SOURCES = \
+ main_test.cpp \
addr_test.cpp \
device_test.cpp \
- cppunit_test.cpp \
usrp_dboard_test.cpp \
wax_test.cpp