aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorRobertWalstab <robert.walstab@gmail.com>2020-07-09 12:10:52 +0200
committerAaron Rossetto <aaron.rossetto@ni.com>2020-07-16 10:00:12 -0500
commit7018ac8e47f23c9765efe33a7068c8f6f2fab14d (patch)
treea7b45983f49f4693c337f5c48db9be935c23783e /mpm/systemd/CMakeLists.txt
parent11821443369ace95af5bc9e2556ca71f6219f960 (diff)
downloaduhd-7018ac8e47f23c9765efe33a7068c8f6f2fab14d.tar.gz
uhd-7018ac8e47f23c9765efe33a7068c8f6f2fab14d.tar.bz2
uhd-7018ac8e47f23c9765efe33a7068c8f6f2fab14d.zip
mpm: systemd: systemd configuration are getting now installed under consideration of the device type
Diffstat (limited to 'mpm/systemd/CMakeLists.txt')
-rw-r--r--mpm/systemd/CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/mpm/systemd/CMakeLists.txt b/mpm/systemd/CMakeLists.txt
index b8f6e5901..32461b7fb 100644
--- a/mpm/systemd/CMakeLists.txt
+++ b/mpm/systemd/CMakeLists.txt
@@ -43,7 +43,19 @@ install(FILES
)
# udev rules
-install(FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/udev/70-sfp-net.rules
- DESTINATION ${UDEV_UDEVDIR}/rules.d
+if(MPM_DEVICE STREQUAL "n3xx")
+ install(FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/udev/n3xx/70-sfp-net.rules
+ DESTINATION ${UDEV_UDEVDIR}/rules.d
+)
+elseif(MPM_DEVICE STREQUAL "e320")
+ install(FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/udev/e3xx/70-sfp-net.rules
+ DESTINATION ${UDEV_UDEVDIR}/rules.d
+)
+elseif(MPM_DEVICE STREQUAL "e31x")
+ install(FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/udev/e3xx/70-sfp-net.rules
+ DESTINATION ${UDEV_UDEVDIR}/rules.d
)
+endif(MPM_DEVICE STREQUAL "n3xx")