aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/python/usrp_mpm/periph_manager/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-11-13 21:53:22 -0800
committerBrent Stapleton <bstapleton@g.hmc.edu>2018-11-14 14:10:09 -0800
commita69ab0c23a0c38e3fed3e412df36538d8959d23c (patch)
treee6669a138dad84f79c46588f43a38c69dda90246 /mpm/python/usrp_mpm/periph_manager/CMakeLists.txt
parent4247f025020d7dd1f696dfbd3cce248957d6ace7 (diff)
downloaduhd-a69ab0c23a0c38e3fed3e412df36538d8959d23c.tar.gz
uhd-a69ab0c23a0c38e3fed3e412df36538d8959d23c.tar.bz2
uhd-a69ab0c23a0c38e3fed3e412df36538d8959d23c.zip
cmake: Update coding style to use lowercase commands
Also updates our coding style file. Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case. Run the following shell code (with GNU compliant sed): cmake --help-command-list | grep -v "cmake version" | while read c; do echo 's/\b'"$(echo $c | tr '[:lower:]' '[:upper:]')"'\(\s*\)(/'"$c"'\1(/g' done > convert.sed \ && git ls-files -z -- bootstrap '*.cmake' '*.cmake.in' \ '*CMakeLists.txt' | xargs -0 gsed -i -f convert.sed && rm convert.sed (Make sure the backslashes don't get mangled!)
Diffstat (limited to 'mpm/python/usrp_mpm/periph_manager/CMakeLists.txt')
-rw-r--r--mpm/python/usrp_mpm/periph_manager/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/mpm/python/usrp_mpm/periph_manager/CMakeLists.txt b/mpm/python/usrp_mpm/periph_manager/CMakeLists.txt
index 0689cdda9..994b1d64a 100644
--- a/mpm/python/usrp_mpm/periph_manager/CMakeLists.txt
+++ b/mpm/python/usrp_mpm/periph_manager/CMakeLists.txt
@@ -7,8 +7,8 @@
########################################################################
# This file included, use CMake directory variables
########################################################################
-SET(USRP_MPM_FILES ${USRP_MPM_FILES})
-SET(USRP_MPM_PERIPHMGR_FILES
+set(USRP_MPM_FILES ${USRP_MPM_FILES})
+set(USRP_MPM_PERIPHMGR_FILES
${CMAKE_CURRENT_SOURCE_DIR}/__init__.py.in
${CMAKE_CURRENT_SOURCE_DIR}/base.py
${CMAKE_CURRENT_SOURCE_DIR}/n3xx.py
@@ -16,5 +16,5 @@ SET(USRP_MPM_PERIPHMGR_FILES
${CMAKE_CURRENT_SOURCE_DIR}/e320.py
${CMAKE_CURRENT_SOURCE_DIR}/e320_periphs.py
)
-LIST(APPEND USRP_MPM_FILES ${USRP_MPM_PERIPHMGR_FILES})
-SET(USRP_MPM_FILES ${USRP_MPM_FILES} PARENT_SCOPE)
+list(APPEND USRP_MPM_FILES ${USRP_MPM_PERIPHMGR_FILES})
+set(USRP_MPM_FILES ${USRP_MPM_FILES} PARENT_SCOPE)