aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/python/usrp_mpm/chips/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2017-05-12 16:55:54 -0700
committerMartin Braun <martin.braun@ettus.com>2017-12-22 15:03:53 -0800
commit5a4a78de6104333307da68b6a0dfc516291ede69 (patch)
treea8fad6471d5df0175dd55e4970a018a8cb2d09b4 /mpm/python/usrp_mpm/chips/CMakeLists.txt
parent9dee6175da45440997c8ed82fbf40f8f380dc4a7 (diff)
downloaduhd-5a4a78de6104333307da68b6a0dfc516291ede69.tar.gz
uhd-5a4a78de6104333307da68b6a0dfc516291ede69.tar.bz2
uhd-5a4a78de6104333307da68b6a0dfc516291ede69.zip
mpm: Factored out common LMK04828 code
Diffstat (limited to 'mpm/python/usrp_mpm/chips/CMakeLists.txt')
-rw-r--r--mpm/python/usrp_mpm/chips/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/mpm/python/usrp_mpm/chips/CMakeLists.txt b/mpm/python/usrp_mpm/chips/CMakeLists.txt
new file mode 100644
index 000000000..438b76038
--- /dev/null
+++ b/mpm/python/usrp_mpm/chips/CMakeLists.txt
@@ -0,0 +1,25 @@
+#
+# Copyright 2017 Ettus Research (National Instruments)
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+SET(USRP_MPM_FILES ${USRP_MPM_FILES})
+SET(USRP_MPM_CHIP_FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/__init__.py
+ ${CMAKE_CURRENT_SOURCE_DIR}/lmk04828.py
+)
+LIST(APPEND USRP_MPM_FILES ${USRP_MPM_CHIP_FILES})
+SET(USRP_MPM_FILES ${USRP_MPM_FILES} PARENT_SCOPE)
+