aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/python/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2017-05-31 18:18:57 -0700
committerMartin Braun <martin.braun@ettus.com>2017-12-22 15:03:58 -0800
commitd16d342be2dee7fef1f798349eba211cce0f27f9 (patch)
treeab213207ea53754550add6542613cf353ff1c2b5 /mpm/python/CMakeLists.txt
parent3aa899e1f5a1e3b7c9e69ccdd19aeb3fe2ffd672 (diff)
downloaduhd-d16d342be2dee7fef1f798349eba211cce0f27f9.tar.gz
uhd-d16d342be2dee7fef1f798349eba211cce0f27f9.tar.bz2
uhd-d16d342be2dee7fef1f798349eba211cce0f27f9.zip
mpm: Made CMake more future-proof w.r.t. newer Boost and Python
Diffstat (limited to 'mpm/python/CMakeLists.txt')
-rw-r--r--mpm/python/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/mpm/python/CMakeLists.txt b/mpm/python/CMakeLists.txt
index 11adef92a..4f2aeb20f 100644
--- a/mpm/python/CMakeLists.txt
+++ b/mpm/python/CMakeLists.txt
@@ -89,7 +89,7 @@ ADD_CUSTOM_COMMAND(OUTPUT ${OUTPUT}
ADD_CUSTOM_TARGET(usrp_mpm ALL DEPENDS ${OUTPUT} pyusrp_periphs)
EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c
- "from distutils import sysconfig; print sysconfig.get_python_lib(plat_specific=True, prefix='')"
+ "from __future__ import print_function; from distutils import sysconfig; print(sysconfig.get_python_lib(plat_specific=True, prefix=''))"
OUTPUT_VARIABLE USRP_MPM_PYTHON_DIR OUTPUT_STRIP_TRAILING_WHITESPACE
)
INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/build/lib/usrp_mpm DESTINATION ${CMAKE_INSTALL_PREFIX}/${USRP_MPM_PYTHON_DIR})