aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/lib/rfdc/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Amsel <lars.amsel@ni.com>2021-06-04 08:27:50 +0200
committerAaron Rossetto <aaron.rossetto@ni.com>2021-06-10 12:01:53 -0500
commit2a575bf9b5a4942f60e979161764b9e942699e1e (patch)
tree2f0535625c30025559ebd7494a4b9e7122550a73 /mpm/lib/rfdc/CMakeLists.txt
parente17916220cc955fa219ae37f607626ba88c4afe3 (diff)
downloaduhd-2a575bf9b5a4942f60e979161764b9e942699e1e.tar.gz
uhd-2a575bf9b5a4942f60e979161764b9e942699e1e.tar.bz2
uhd-2a575bf9b5a4942f60e979161764b9e942699e1e.zip
uhd: Add support for the USRP X410
Co-authored-by: Lars Amsel <lars.amsel@ni.com> Co-authored-by: Michael Auchter <michael.auchter@ni.com> Co-authored-by: Martin Braun <martin.braun@ettus.com> Co-authored-by: Paul Butler <paul.butler@ni.com> Co-authored-by: Cristina Fuentes <cristina.fuentes-curiel@ni.com> Co-authored-by: Humberto Jimenez <humberto.jimenez@ni.com> Co-authored-by: Virendra Kakade <virendra.kakade@ni.com> Co-authored-by: Lane Kolbly <lane.kolbly@ni.com> Co-authored-by: Max Köhler <max.koehler@ni.com> Co-authored-by: Andrew Lynch <andrew.lynch@ni.com> Co-authored-by: Grant Meyerhoff <grant.meyerhoff@ni.com> Co-authored-by: Ciro Nishiguchi <ciro.nishiguchi@ni.com> Co-authored-by: Thomas Vogel <thomas.vogel@ni.com>
Diffstat (limited to 'mpm/lib/rfdc/CMakeLists.txt')
-rw-r--r--mpm/lib/rfdc/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/mpm/lib/rfdc/CMakeLists.txt b/mpm/lib/rfdc/CMakeLists.txt
new file mode 100644
index 000000000..a7401fd7b
--- /dev/null
+++ b/mpm/lib/rfdc/CMakeLists.txt
@@ -0,0 +1,19 @@
+#
+# Copyright 2019 Ettus Research, National Instruments Brand
+#
+# SPDX-License-Identifier: GPL-3.0
+#
+set(RFDC_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/rfdc_ctrl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/rfdc_throw.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/xrfdc_clock.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/xrfdc_g.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/xrfdc_intr.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/xrfdc_mb.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/xrfdc_mixer.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/xrfdc_mts.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/xrfdc_sinit.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/xrfdc.c
+)
+
+USRP_PERIPHS_ADD_OBJECT(rfdc ${RFDC_SOURCES})