aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Williams <alex.williams@ni.com>2018-04-17 10:36:59 -0700
committerMartin Braun <martin.braun@ettus.com>2018-04-18 15:34:51 -0700
commit7dcd16f5a6980cb1183bf1a10812c952d92c4ddb (patch)
treed1eaa9bdca563fe1f17886d771e16ff65ed153c7 /mpm/lib/CMakeLists.txt
parente733e590c4b5aa3053af0681bef199d27e4b2d7a (diff)
downloaduhd-7dcd16f5a6980cb1183bf1a10812c952d92c4ddb.tar.gz
uhd-7dcd16f5a6980cb1183bf1a10812c952d92c4ddb.tar.bz2
uhd-7dcd16f5a6980cb1183bf1a10812c952d92c4ddb.zip
mpm: Use configurable components for build system
For a minimal build, default to off for components unless the MPM_DEVICE or the user requests it specifically.
Diffstat (limited to 'mpm/lib/CMakeLists.txt')
-rw-r--r--mpm/lib/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/mpm/lib/CMakeLists.txt b/mpm/lib/CMakeLists.txt
index 091c2c25f..cf252f6e6 100644
--- a/mpm/lib/CMakeLists.txt
+++ b/mpm/lib/CMakeLists.txt
@@ -11,9 +11,9 @@ ADD_SUBDIRECTORY(chips)
ADD_SUBDIRECTORY(spi)
ADD_SUBDIRECTORY(types)
-if(MPM_DEVICE STREQUAL "n3xx")
+if(ENABLE_MYKONOS)
ADD_SUBDIRECTORY(mykonos)
-endif(MPM_DEVICE STREQUAL "n3xx")
+endif(ENABLE_MYKONOS)
USRP_PERIPHS_ADD_OBJECT(periphs
exception.cpp