aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Hofrichter <joerg.hofrichter@ni.com>2020-02-07 09:06:38 +0100
committeratrnati <54334261+atrnati@users.noreply.github.com>2020-02-10 10:19:26 -0600
commitc0a6bb1720a3db8ac9a40bdd5ca19de8be40d500 (patch)
treef25ecd8811b04be945031da60c2ff273bacc340f /mpm/CMakeLists.txt
parent414469abeb2cc0038ccb4157593414b9ebc93830 (diff)
downloaduhd-c0a6bb1720a3db8ac9a40bdd5ca19de8be40d500.tar.gz
uhd-c0a6bb1720a3db8ac9a40bdd5ca19de8be40d500.tar.bz2
uhd-c0a6bb1720a3db8ac9a40bdd5ca19de8be40d500.zip
mpm: cmake: added date_time as required boost component
this fixes the error of a missing symbol _ZNK5boost9gregorian10greg_month15as_short_stringEv in /usr/lib/libusrp-periphs.so.4 when building with Boost 1.71
Diffstat (limited to 'mpm/CMakeLists.txt')
-rw-r--r--mpm/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/mpm/CMakeLists.txt b/mpm/CMakeLists.txt
index ce40b7caa..c41b3fce1 100644
--- a/mpm/CMakeLists.txt
+++ b/mpm/CMakeLists.txt
@@ -77,6 +77,7 @@ message(STATUS "Configuring Boost C++ Libraries...")
set(BOOST_REQUIRED_COMPONENTS
system
thread
+ date_time
)
# Same as with Python version: MPM might work with other versions of Boost,
# but we don't make any guarantees.